WebWork Magazin - Design, Gestaltung, Online Medien, html

Webhosting Provider Domain

Home | Registrieren | Einloggen | Suchen | Aktuelles | Suleitec Webhosting
Reparatur-Forum | Elektro forum | Ersatzteilshop Haushalt und Elektronik



Im Homepage und Webhosting-Forum --- Wordpress-Seite: Problem in Internet Explorer - aber nicht in Firefox, Chrome, etc

Scripte und Programme für PHP, MYSQL. Diskussionen zur Programmierung im Web. FRagen zu CMS, Blogsoftware, Shops, Newsletter und vielen weiteren Scripten.

Forum » PHP & MySQL » Wordpress-Seite: Problem in Internet Explorer - aber nicht i... - 30 Jan 2015 Antworten
im Forum für Webhosting Homepage gefunden:
Wordpress-Seite: Problem in Internet Explorer - aber nicht in Firefox, Chrome, etc
fandango79
Pixelschubser
Threadstarter




Beiträge: 4

Hallo zusammen;

ich habe auf Basis von Wordpress eine Website erstellt, ein Template insofern angepasst, daß ich
- Farben in der CSS angepasst hab
- Grafische Elemente (jpgs) durch gleichnamige, gleichgroße Dateien ausgetauscht hab
- Funktionen entfernt, die ich nicht benötigt hab

Jetzt tritt folgender Fehler auf:
einige der von mir geänderten grafik-elemente werden in ie7, ie8 nicht angezeigt, auch auf verschiedenen rechnern. Chrome, Firefox etc haben keine Probleme damit. ie9 habe ich noch nicht, und kann das derzeit auch nicht testen.

w3c zeigt mit 4 Fehler an, die aber nach meiner Meionung nichts mit dem Fehler zu tun haben sollten.
Und jetzt - ihr lest es aus meinen Zeilen - bin ich ratlos.

Link zur Homepage: www.CMCS.eu
Link zum CSS:

CSS

wer kann helfen? DANKE!

  Profil   Editieren   Zitieren
Rieke
Foren-Team





Beiträge: 1727

Vielleicht war es keine gute Idee den Autoren Ihre Lorbeeren zu klauen und gleich alles komplett zu ändern, da schleichen sich schnell Fehler ein, die von aussen schwer zu finden sind.

http://themes.wordpress-deutschland.org/wp-multiflex-3/

Der Orginal Code der Seiten Navigation:
1:
#wrap { 	background: url(images/bg_main_withnav.jpg) repeat-y top left; 	width: 900px; 	margin:  0 auto; 	border: 1px solid #333333; }


Dein Code der Seiten navigation
1: 
2: 
3: 
4: 
5:
#wrap {
    background: url("images/bg_main_withnav.jpg") repeat-y scroll left top transparent;
    border: 1px solid #333333;
    margin: 0 auto;
    width: 900px;}


Vielleicht tauscht du als ersten test einmal das "repeat-y scroll left top transparent" wieder gegen "repeat-y top left" aus und schaust ob dann die Navigation im IE sichtbar wird.

Aber generell würde ich dir ein anderes, neuwertigeres Template empfehlen, es ist eben schon über 4 Jahre alt und basiert auf einem noch älteren Model, in der Zeit hat Wordpress und das Internet wahre Sprünge vollzogen, so dass ich bei einer neuen Seite nicht mehr auf ein so rustikales Template setzen würde.

Dennoch viel Erfolg!

---

Diese Nachricht wurde geändert von: Rieke
  Profil   E-Mail   Website   Editieren   Zitieren
fandango79
Pixelschubser
Threadstarter




Beiträge: 4

Hallo Rieke, und vielen dank für die Hinweise - die Anpassungen hab ich soweit gemacht - allerdings kann ich mir die Änderungen, die Du gefunden hast nicht ganz erklären - den Transparent Flag hab ich nicht gesetzt, leider hat das die Thematik noch nicht behoben. Ich habe jetzt aber herausgefunden, was die Ursache ist - auch wenn ich mir das - ebenfalls - nicht ganz erklären kann: Es liegt an den geänderten Grafiken: die alten Grafiken in mein "editiertes" Theme wieder eingefügt --> et voila, es funktioniert. Gegenprobe: Meine Grafiken ins ansonsten "Vanilla" Theme eingefügt: --> gleicher Fehler wie zuvor. Es liegt also - wieso auch immer - an den geänderten (allerdings identisch benamsten, sonst würd es ja gar nicht funktionieren) JPGs...

Ich hab mir Deinen weiteren Rat, ein moderneres Theme zu nutzen ebenfalls zu Herzen genommen, eine entsprechende Überarbeitung wird geschehen - mit sanfteren Anpassungen

VIELEN Dank für die schnelle, verständliche Hilfestellung

  Profil   Editieren   Zitieren
Rieke
Foren-Team





Beiträge: 1727

Das mit den Bildern verstehe ich nicht. Wenn das Bild xyz.jpg durch ein neues xyz.jpg ausgetauscht wird, es im Firefox funktioniert (damit steht fest das die Bild Datei nicht "defekt" ist) dann verstehe ich nicht, warum die Datei im IE nicht mehr funktionieren sollte.

Hast du mal versucht ob du die URL des Bildes, also ... das Bild selbst, im IE öffnen kannst ? Sehr sehr eigenartig

---

  Profil   E-Mail   Website   Editieren   Zitieren
fandango79
Pixelschubser
Threadstarter




Beiträge: 4

xyz.jpg durch anderes xyz.jpg ersetzen ist genau was ich gemacht hab. Pixelgröße ist identisch. Dateigröße etwas größer. von daher MUSS es *eigentlich* funktionieren... so auch meine Denke...

Die betreffenden jpgs in IE zu öffnen hatt ich probiert, funktioniert *nicht* - es wird das berühmte rote x des Todes angezeigt...

und den hab ich grad auch auf dem Kopf sitzen... ;)

Diese Nachricht wurde geändert von: fandango79
  Profil   Editieren   Zitieren
fandango79
Pixelschubser
Threadstarter




Beiträge: 4

lösung gefunden...

IE kann keine JPGs im CMYK-Format darstellen, sondern ausschließlich RGB - Firefox, Chrome und Konsorten sind nicht so wählerisch und verzeihen solche (Ironie) katastrophalen Formfehler (/Ironie) ...

--> Bild zum Test als RGB-JPG und es tut auch mit dem IE...

  Profil   Editieren   Zitieren
 

Antworten


Forum » PHP & MySQL » Wordpress-Seite: Problem in Internet Explorer - aber nicht i...

Aktuelle Beiträge zur Hilfe im Forum für Homepage - Wordpress-Seite: Problem in Internet Explorer - aber nicht in Firefox, Chrome, etc im Forum Homepage Hosting AntwortenLetztes Posting
CMS für Online Shop
in "PHP & MySQL"
5 19.12.2014 13:28 von pabloxb
Regestrierungproblem
in "PHP & MySQL"
1 24.09.2014 19:14 von Dario
Text basierender Chat
in "PHP & MySQL"
4 18.08.2014 16:27 von peterkaiser
IP-Adresse auf Richtigkeit überprüfen (RegEx)
in "PHP & MySQL"
19 22.04.2014 07:15 von ezra20
Besuche von Google Images Monitoren
in "PHP & MySQL"
0 07.10.2013 17:10 von maze0002
suche online community script
in "PHP & MySQL"
2 25.08.2013 14:40 von jebote
PHP befehl ausführen
in "PHP & MySQL"
8 25.07.2013 06:23 von judy321
Callback Befehl ++ Session ID Eintrag +++
in "PHP & MySQL"
0 19.04.2013 16:05 von empstudios
php wird nicht angezeigt
in "PHP & MySQL"
2 21.12.2012 17:12 von Liam
mit hash_hmac() erzeugte Signatur für OAuth twitter API ist falsch
in "PHP & MySQL"
2 07.09.2012 12:47 von Ralli12
FOPEN dauert Ewig
in "PHP & MySQL"
14 02.09.2012 21:54 von frieger
[PHP] - Fatal error: Allowed memory size of 8388608 bytes exhausted
in "PHP & MySQL"
15 30.08.2012 12:33 von teiger
Senior Software Entwickler in Hannover gesucht
in "PHP & MySQL"
1 23.08.2012 18:39 von svenschumacher
Bilder kleiner machen -D
in "PHP & MySQL"
17 18.08.2012 14:24 von frank katzer
Fehler im SQL Statement?
in "PHP & MySQL"
2 05.07.2012 00:43 von Ori



Besucher : 3968764    Heute : 166     Gestern : 2664     Online : 31     30.1.2015    1:20      1 Besucher in den letzten 60 Sekunden        
alle 60.00 Sekunden ein neuer Besucher
Die letzten 30 Referrer :

1 22:58 - google.de/search - freenet störung
2 21:35 - https://qwant.com/ - Ubuntu Qwant
3 21:19 - google.at/search - handy von freunden suchen
4 19:54 - google.de/cse - gutscheinflagge
5 18:54 - bing.com/search - 3D Objekte im Web
6 15:08 - bing.com/search - php aktuelle url aufrufen
7 14:35 - google.de/search - telekom whatsapp
8 12:55 - bing.com/search - durschnittliches jahres netto einkommen 2014
9 12:51 - https://de.qwant.com/ - Internetspezialist Asbach
10 12:18 - bing.com/search - php ordner upload
11 10:28 - bing.com/search - ISEE maschinencode auslesen
12 8:10 - bing.com/search - mail impercid.com.br loc:DE
13 6:34 - https://qwant.com/ - tanzender groot gif
14 3:55 - de.search.yahoo.com/search - mail ich-blicks.net
15 1:39 - google.com/search - auto_increment wert
16 0:31 - https://qwant.com/ - qwant bildersuche
17 23:13 - google.de/search - WooCommerce Katalog funktion
18 21:25 - de.wow.com/search - freundin orten
19 20:55 - bing.com/search - das neue Passwort hundert seiten
20 20:28 - de.ask.com/web - gmx email abrufen
21 20:13 - google.at/search - wordpress funktioniert nicht im explorer
22 17:23 - https://qwant.com/ - problem qwant dienstag
23 17:10 - google.com/search - telekom whatsapp
24 16:10 - https://qwant.com/ - url direkt aufrufen
25 14:46 - google.at/search - Eigene server einrichten
26 14:34 - https://qwant.com/ - url direkt aufrufen
27 11:45 - bing.com/search - css bild in div zentrieren
28 10:57 - google.de/search - was ist mit psn los ?
29 10:38 - google.de/search - auswahl drehen photoshop
30 10:00 - - Fehler C00D11BA

Nach oben